Skip navigation.

Technical Requirements for Using Meet & Confer, Teach & Confer and Office Hours

Technical requirements for presenting or participating in live or archived meetings are shown below.
Click the link to take you to the details.

Supported Operating Systems & Browsers

Supported configurations have been tested and work with Meet & Confer, Teach & Confer and Office Hours.


CCC Confer Supported Operating Systems & Browsers

OS Browser Supported Unsupported
WinXP
Win2000
Internet Explorer 5.0 - 6.0
Firefox 1.0 - 1.5
Other AOL, Opera
   
   
OS Browser Supported Unsupported
Mac OS ¹‚²
10.4
10.3
Safari 1.2 - 2.0
Firefox 1.0 - 1.5.0.0 1.5.0.1+
Other   AOL, Opera, IE
 
   
OS Browser Supported Unsupported¹
Linux ¹ Mozilla 1.0 - 1.7
Firefox 1.0 - 2.0
Other Opera

Note: Browsers listed in the Supported column are recommended browsers for use with CCC Confer.
Browsers not listed have not been tested and are not supported.

Note: Windows 98 & Millenium: Microsoft stopped supporting in July 2006
Macintosh 10.2: Apple stopped releasing new updates at the end of 2004


Intel-based Macs: Presently, Safari is the only supported browser. Due to a bug in the way Java is handled by Firefox on Intel based Macs, required applets will cause the browser to crash. This is a known issue and Mozilla is currently working to resolve this bug. (Firefox does work with all non-Intel, or PowerPC Macs. A fix is expected in the next release of FIrefox.)

Linux: Presenters cannot display content via Application Sharing using Linux. However, participants using Linux can view Application Sharing content

Back to top of page.

Live Meetings - Basic Technical Requirements

Presenters - Instructors Participants - Students
Win 98SE+, Mac OSX 10.2+, or Linux Windows 98SE+, Mac OSX 10.2+, or Linux
256 MB RAM (higher recommended) 128 MB RAM (256 MB recommended)
Broadband Internet access Internet access at 56k (or faster)
Sun Java installed http://java.sun.com/j2se/1.5.0/download.jsp Sun Java installed http://java.sun.com/j2se/1.5.0/download.jsp
Browser must be java script enabled Browser must be java script enabled
Disable pop-up blockers Disable pop-up blockers
Back to top of page.

Live Meetings Using VOIP

Presenters - Instructors Participants - Students
Basic Technical Requirements Basic Technical Requirements
Sound card Sound card
Microphone - speakers (integrated headset recommended) Microphone - speakers (integrated headset recommended)
Must accept signed applet distributed by HorizonWimba. Must accept signed applet distributed by HorizonWimba.
Back to top of page.

Live Meetings Using Application Sharing

Presenters - Instructors Participants - Students
Only required if asked to share your computer
Basic Technical Requirements Basic Technical Requirements
Must accept signed applet distributed by HorizonWimba. Must accept signed applet distributed by HorizonWimba.
Back to top of page.

Archived Meetings

Presenters - Instructors Participants - Students
Basic Technical Requirements Basic Technical Requirements
QuickTime Player 6.5+ http://www.quicktime.com QuickTime Player 6.5+ http://www.quicktime.com
Sound Card Sound Card
Disable pop-up blockers Disable pop-up blockers
Back to top of page.